import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"courselectureid\":(\\d+)";
final String string = "\"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4\",\"metainfoid\":877,\"courselectureid\":1429\n"
+ "\"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4\",\"metainfoid\":877,\"courselectureid\":1429\n"
+ "\"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4\",\"metainfoid\":877,\"courselectureid\":1429\n"
+ "\"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4\",\"metainfoid\":877,\"courselectureid\":1429\n"
+ "\"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4\",\"metainfoid\":877,\"courselectureid\":1429";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}