re = /"courselectureid":(\d+)/
str = '"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429
"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429
"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429
"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429
"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end