// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""courselectureid":(\d+)"#).unwrap();
let string = "\"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4\",\"metainfoid\":877,\"courselectureid\":1429
\"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4\",\"metainfoid\":877,\"courselectureid\":1429
\"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4\",\"metainfoid\":877,\"courselectureid\":1429
\"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4\",\"metainfoid\":877,\"courselectureid\":1429
\"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4\",\"metainfoid\":877,\"courselectureid\":1429";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}