$re = '/"courselectureid":(\d+)/';
$str = '"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429
"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429
"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429
"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429
"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);