const regex = /"courselectureid":(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"courselectureid":(\\d+)', 'g')
const str = `"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429
"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429
"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429
"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429
"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}