import re
regex = re.compile(r"\"courselectureid\":(\d+)")
test_str = ("\"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4\",\"metainfoid\":877,\"courselectureid\":1429\n"
"\"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4\",\"metainfoid\":877,\"courselectureid\":1429\n"
"\"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4\",\"metainfoid\":877,\"courselectureid\":1429\n"
"\"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4\",\"metainfoid\":877,\"courselectureid\":1429\n"
"\"1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4\",\"metainfoid\":877,\"courselectureid\":1429")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")