#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(A(\d{8})00|(A(\d{7})00))"
Local $sString = "//Should match:" & @CRLF & _
"ABC12345678CRP1234567F2801209A1234567800<<<33" & @CRLF & _
"ABC12345678CRP1234567F2801209A123456700<<<33" & @CRLF & _
"" & @CRLF & _
"//Should not match:" & @CRLF & _
"ABC12345678CRP1234567F2801209B1234567800<<<33 (starts with B)" & @CRLF & _
"ABC12345678CRP1234567F2801209A12345600<<<33 (less than 7 or 8 digits)" & @CRLF & _
"ABC12345678CRP1234567F2801209A1234567899<<<33 (ends with 99)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")