using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(A(\d{8})00|(A(\d{7})00))";
string input = @"//Should match:
ABC12345678CRP1234567F2801209A1234567800<<<33
ABC12345678CRP1234567F2801209A123456700<<<33
//Should not match:
ABC12345678CRP1234567F2801209B1234567800<<<33 (starts with B)
ABC12345678CRP1234567F2801209A12345600<<<33 (less than 7 or 8 digits)
ABC12345678CRP1234567F2801209A1234567899<<<33 (ends with 99)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}