import re
regex = re.compile(r"(A(\d{8})00|(A(\d{7})00))", flags=re.MULTILINE)
test_str = ("//Should match:\n"
"ABC12345678CRP1234567F2801209A1234567800<<<33\n"
"ABC12345678CRP1234567F2801209A123456700<<<33\n\n"
"//Should not match:\n"
"ABC12345678CRP1234567F2801209B1234567800<<<33 (starts with B)\n"
"ABC12345678CRP1234567F2801209A12345600<<<33 (less than 7 or 8 digits)\n"
"ABC12345678CRP1234567F2801209A1234567899<<<33 (ends with 99)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")