// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(A(\d{8})00|(A(\d{7})00))").unwrap();
let string = "//Should match:
ABC12345678CRP1234567F2801209A1234567800<<<33
ABC12345678CRP1234567F2801209A123456700<<<33
//Should not match:
ABC12345678CRP1234567F2801209B1234567800<<<33 (starts with B)
ABC12345678CRP1234567F2801209A12345600<<<33 (less than 7 or 8 digits)
ABC12345678CRP1234567F2801209A1234567899<<<33 (ends with 99)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}