package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(A(\d{8})00|(A(\d{7})00))`)
var str = `//Should match:
ABC12345678CRP1234567F2801209A1234567800<<<33
ABC12345678CRP1234567F2801209A123456700<<<33
//Should not match:
ABC12345678CRP1234567F2801209B1234567800<<<33 (starts with B)
ABC12345678CRP1234567F2801209A12345600<<<33 (less than 7 or 8 digits)
ABC12345678CRP1234567F2801209A1234567899<<<33 (ends with 99)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}