import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(A(\\d{8})00|(A(\\d{7})00))";
final String string = "//Should match:\n"
+ "ABC12345678CRP1234567F2801209A1234567800<<<33\n"
+ "ABC12345678CRP1234567F2801209A123456700<<<33\n\n"
+ "//Should not match:\n"
+ "ABC12345678CRP1234567F2801209B1234567800<<<33 (starts with B)\n"
+ "ABC12345678CRP1234567F2801209A12345600<<<33 (less than 7 or 8 digits)\n"
+ "ABC12345678CRP1234567F2801209A1234567899<<<33 (ends with 99)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}