use strict;
my $str = '//Should match:
ABC12345678CRP1234567F2801209A1234567800<<<33
ABC12345678CRP1234567F2801209A123456700<<<33
//Should not match:
ABC12345678CRP1234567F2801209B1234567800<<<33 (starts with B)
ABC12345678CRP1234567F2801209A12345600<<<33 (less than 7 or 8 digits)
ABC12345678CRP1234567F2801209A1234567899<<<33 (ends with 99)
';
my $regex = qr/(A(\d{8})00|(A(\d{7})00))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}