# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)(?:^(?=.*&.*&)|(?!^)\G)[^&\n]*\K&(?=.*&)/,/g;t' <<< "GROUP 1
GROUP 1 & GROUP 2
GROUP 1 & GROUP 2 & GROUP 3
GROUP 1 & GROUP 2 & GROUP 3 & GROUP 4
"