const regex = /(?m)(?:^(?=.*&.*&)|(?!^)\G)[^&\n]*\K&(?=.*&)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)(?:^(?=.*&.*&)|(?!^)\\G)[^&\\n]*\\K&(?=.*&)', 'g')
const str = `GROUP 1
GROUP 1 & GROUP 2
GROUP 1 & GROUP 2 & GROUP 3
GROUP 1 & GROUP 2 & GROUP 3 & GROUP 4
`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);