import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?:^(?=.*&.*&)|(?!^)\\G)[^&\\n]*\\K&(?=.*&)";
final String string = "GROUP 1\n"
+ "GROUP 1 & GROUP 2\n"
+ "GROUP 1 & GROUP 2 & GROUP 3\n"
+ "GROUP 1 & GROUP 2 & GROUP 3 & GROUP 4\n";
final String subst = ",";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}