import Foundation
let pattern = #"(?m)(?:^(?=.*&.*&)|(?!^)\G)[^&\n]*\K&(?=.*&)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
GROUP 1
GROUP 1 & GROUP 2
GROUP 1 & GROUP 2 & GROUP 3
GROUP 1 & GROUP 2 & GROUP 3 & GROUP 4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)