re = /(?m)(?:^(?=.*&.*&)|(?!^)\G)[^&\n]*\K&(?=.*&)/
str = 'GROUP 1
GROUP 1 & GROUP 2
GROUP 1 & GROUP 2 & GROUP 3
GROUP 1 & GROUP 2 & GROUP 3 & GROUP 4
'
subst = ','
result = str.gsub(re, subst)
# Print the result of the substitution
puts result