use strict;
my $str = 'GROUP 1
GROUP 1 & GROUP 2
GROUP 1 & GROUP 2 & GROUP 3
GROUP 1 & GROUP 2 & GROUP 3 & GROUP 4
';
my $regex = qr/(?m)(?:^(?=.*&.*&)|(?!^)\G)[^&\n]*\K&(?=.*&)/p;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";