# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)(?:^(?=.*&.*&)|(?!^)\G)[^&\n]*\K&(?=.*&)"
test_str = ("GROUP 1\n"
"GROUP 1 & GROUP 2\n"
"GROUP 1 & GROUP 2 & GROUP 3\n"
"GROUP 1 & GROUP 2 & GROUP 3 & GROUP 4\n")
subst = ","
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.