#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<Number>(\d+\s)+<\/Number>"
Local $sString = "something else" & @CRLF & _
"" & @CRLF & _
"<Number>65" & @CRLF & _
"46" & @CRLF & _
"4564" & @CRLF & _
"132" & @CRLF & _
"654" & @CRLF & _
"132" & @CRLF & _
"1565" & @CRLF & _
"</Number>" & @CRLF & _
"" & @CRLF & _
"something other"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")