re = /<Number>(\d+\s)+<\/Number>/m
str = 'something else
<Number>65
46
4564
132
654
132
1565
</Number>
something other'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end