import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<Number>(\\d+\\s)+<\\/Number>";
final String string = "something else\n\n"
+ "<Number>65\n"
+ "46\n"
+ "4564\n"
+ "132\n"
+ "654\n"
+ "132\n"
+ "1565\n"
+ "</Number>\n\n"
+ "something other";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}