$re = '/<Number>(\d+\s)+<\/Number>/m';
$str = 'something else
<Number>65
46
4564
132
654
132
1565
</Number>
something other';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);