import re
regex = re.compile(r"<Number>(\d+\s)+<\/Number>", flags=re.MULTILINE)
test_str = ("something else\n\n"
"<Number>65\n"
"46\n"
"4564\n"
"132\n"
"654\n"
"132\n"
"1565\n"
"</Number>\n\n"
"something other")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")