// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<Number>(\d+\s)+<\/Number>").unwrap();
let string = "something else
<Number>65
46
4564
132
654
132
1565
</Number>
something other";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}