package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<Number>(\d+\s)+<\/Number>`)
var str = `something else
<Number>65
46
4564
132
654
132
1565
</Number>
something other`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}