#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(https?:\/\/)?steamcommunity\.com\/tradeoffer\/new\/\?partner=[0-9]+&token=[a-zA-Z0-9_-]+$"
Local $sString = "http://steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM" & @CRLF & _
"" & @CRLF & _
"https://steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM" & @CRLF & _
"" & @CRLF & _
"steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM" & @CRLF & _
"" & @CRLF & _
"http://steamcommunity.com/tradeoffer/new/?partner=23&token=" & @CRLF & _
"" & @CRLF & _
"http://steamcommunity.com/tradeoffer/new/?partner=&token=KasdTM" & @CRLF & _
"" & @CRLF & _
"http://google.com/tradeoffer/new/?partner=23&token=KasdTM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")