import re
regex = re.compile(r"^(https?:\/\/)?steamcommunity\.com\/tradeoffer\/new\/\?partner=[0-9]+&token=[a-zA-Z0-9_-]+$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("http://steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM\n\n"
"https://steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM\n\n"
"steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM\n\n"
"http://steamcommunity.com/tradeoffer/new/?partner=23&token=\n\n"
"http://steamcommunity.com/tradeoffer/new/?partner=&token=KasdTM\n\n"
"http://google.com/tradeoffer/new/?partner=23&token=KasdTM")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")