use strict;
my $str = 'http://steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM
https://steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM
steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM
http://steamcommunity.com/tradeoffer/new/?partner=23&token=
http://steamcommunity.com/tradeoffer/new/?partner=&token=KasdTM
http://google.com/tradeoffer/new/?partner=23&token=KasdTM';
my $regex = qr/^(https?:\/\/)?steamcommunity\.com\/tradeoffer\/new\/\?partner=[0-9]+&token=[a-zA-Z0-9_-]+$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}