$re = '/^(https?:\/\/)?steamcommunity\.com\/tradeoffer\/new\/\?partner=[0-9]+&token=[a-zA-Z0-9_-]+$/im';
$str = 'http://steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM
https://steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM
steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM
http://steamcommunity.com/tradeoffer/new/?partner=23&token=
http://steamcommunity.com/tradeoffer/new/?partner=&token=KasdTM
http://google.com/tradeoffer/new/?partner=23&token=KasdTM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);