// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^(https?:\/\/)?steamcommunity\.com\/tradeoffer\/new\/\?partner=[0-9]+&token=[a-zA-Z0-9_-]+$").unwrap();
let string = "http://steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM
https://steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM
steamcommunity.com/tradeoffer/new/?partner=23&token=KasdTM
http://steamcommunity.com/tradeoffer/new/?partner=23&token=
http://steamcommunity.com/tradeoffer/new/?partner=&token=KasdTM
http://google.com/tradeoffer/new/?partner=23&token=KasdTM";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}