# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)(?<d1>\d),(?<d2>\d{1,3})(?!\S)/$1$2/gm;t' <<< "9999
9,999
1,9
12,111
10,000
1,000,000"