#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\S)(?<d1>\d),(?<d2>\d{1,3})(?!\S)"
Local $sString = "9999" & @CRLF & _
"9,999" & @CRLF & _
"1,9" & @CRLF & _
"12,111" & @CRLF & _
"" & @CRLF & _
"10,000" & @CRLF & _
"1,000,000"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)