import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(?<d1>\\d),(?<d2>\\d{1,3})(?!\\S)";
final String string = "9999\n"
+ "9,999\n"
+ "1,9\n"
+ "12,111\n\n"
+ "10,000\n"
+ "1,000,000";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}