use strict;
my $str = '9999
9,999
1,9
12,111
10,000
1,000,000';
my $regex = qr/(?<!\S)(?<d1>\d),(?<d2>\d{1,3})(?!\S)/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";