re = /(?<!\S)(?<d1>\d),(?<d2>\d{1,3})(?!\S)/m
str = '9999
9,999
1,9
12,111
10,000
1,000,000'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result