# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\S)(?<d1>\d),(?<d2>\d{1,3})(?!\S)"
test_str = ("9999\n"
"9,999\n"
"1,9\n"
"12,111\n\n"
"10,000\n"
"1,000,000")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.