const regex = /(?<!\S)(?<d1>\d),(?<d2>\d{1,3})(?!\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)(?<d1>\\d),(?<d2>\\d{1,3})(?!\\S)', 'gm')
const str = `9999
9,999
1,9
12,111
10,000
1,000,000`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);