using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(?<d1>\d),(?<d2>\d{1,3})(?!\S)";
string substitution = @"$1$2";
string input = @"9999
9,999
1,9
12,111
10,000
1,000,000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}