# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(bl)(ue)//g;t' <<< "Mr Blue has a blue house and a blue car"