use strict;
my $str = 'Mr Blue has a blue house and a blue car';
my $regex = qr/(bl)(ue)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";