import Foundation
let pattern = #"(bl)(ue)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Mr Blue has a blue house and a blue car"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)