using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^(?:...(?:....)*)?)r";
string substitution = @"m";
string input = @"it is a test string.
rxxrxxxrxxxrxxxrxxxr
rrrrrrrrrrrrrrrrrrrr";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}