import Foundation
let pattern = #"(?<=^(?:...(?:....)*)?)r"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
it is a test string.
rxxrxxxrxxxrxxxrxxxr
rrrrrrrrrrrrrrrrrrrr
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"m"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)