re = /(?<=^(?:...(?:....)*)?)r/m
str = 'it is a test string.
rxxrxxxrxxxrxxxrxxxr
rrrrrrrrrrrrrrrrrrrr'
subst = 'm'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result