import re
regex = re.compile(r"(?<=^(?:...(?:....)*)?)r", flags=re.MULTILINE)
test_str = ("it is a test string.\n"
"rxxrxxxrxxxrxxxrxxxr\n"
"rrrrrrrrrrrrrrrrrrrr")
subst = "m"
result = regex.sub(subst, test_str)
if result:
print(result)