import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^(?:...(?:....)*)?)r";
final String string = "it is a test string.\n"
+ "rxxrxxxrxxxrxxxrxxxr\n"
+ "rrrrrrrrrrrrrrrrrrrr";
final String subst = "m";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}