const regex = /(?<=^(?:...(?:....)*)?)r/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^(?:...(?:....)*)?)r', 'gm')
const str = `it is a test string.
rxxrxxxrxxxrxxxrxxxr
rrrrrrrrrrrrrrrrrrrr`;
const subst = `m`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);