# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<div class="whatever">(.*?)(<div[^>]*>((?>(?:(?!<\\/?div)[^\n])+|\n|(?2))*)<\\/div>)(.*?)<\\/div>/\1\2\4/gmus;t' <<< "
<div class=\"tutu\">
Blahblah.
<div class=\"whatever\">
Blahblah0.
<div class=\"tata\">
Blahblah1.
</div>
Blahblah2.
</div>
Blahblah3.
</div>
"